Problems Logging In Reported - Investigating
Incident Report for Logikcull
Resolved
The incident impacting users' ability to login has been resolved. Thank you for your patience!
Posted Mar 13, 2023 - 12:47 EDT
Monitoring
Error rates for logins continue to decrease while engineers continue to closely monitor the situation. Thank you for your patience.
Posted Mar 13, 2023 - 12:30 EDT
Investigating
We are investigating customer reports of intermittent issues with our login page and are working to identify and remediate the problem.
Posted Mar 13, 2023 - 12:16 EDT
This incident affected: Logikcull.com.