Email delivery delays from notifications@logikcull.com
Incident Report for Logikcull
Resolved
This incident has been resolved.
Posted Jan 04, 2023 - 21:32 EST
Monitoring
Email messages sent from notifications@logikcull.com are now successfully being delivered. We will continue to monitor email delivery as systems recover. Please contact us at support@logikcull.com with any questions or concerns. Thank you for your patience!
Posted Jan 04, 2023 - 21:14 EST
Update
Email messages sent from notifications@logikcull.com continue to experience delays. Thank you for your patience.

Please contact support@logikcull.com for assistance with new user invitations and ShareSafe notifications.
Posted Jan 04, 2023 - 20:37 EST
Investigating
Email messages sent from notifications@logikcull.com are currently experiencing delays. Please contact support@logikcull.com for assistance with new user invitations and ShareSafe notifications.
Posted Jan 04, 2023 - 20:04 EST
This incident affected: Application emails.