Reports of site availability and performance issues
Incident Report for Logikcull
Resolved
This incident has been resolved. Thank you for your patience!
Posted Jan 31, 2023 - 14:53 EST
Monitoring
Access to Logikcull and document processing have fully recovered. Engineers continue to monitor the system closely. Thanks for your patience!
Posted Jan 31, 2023 - 14:48 EST
Identified
We have identified the root cause of the issues reported earlier. Engineers are actively working to fully restore site availability and document processing. Thank you for your patience!
Posted Jan 31, 2023 - 14:02 EST
Investigating
We're actively investigating reports of site availability and performance issues impacting uploads and downloads. Thank you for your patience!
Posted Jan 31, 2023 - 13:30 EST
This incident affected: Logikcull.com and Document Processing.