Reports of slowness
Incident Report for Logikcull
Resolved
The underlying issue responsible for slowness earlier this morning has been identified and resolved.
Posted over 2 years ago. Jan 09, 2017 - 13:21 EST
Investigating
The engineering team is investigating reports of slowness in the application.
Posted over 2 years ago. Jan 09, 2017 - 12:28 EST