Reports of slow performance
Incident Report for Logikcull
Resolved
Normal operation of Logikcull has resumed.
Posted 7 months ago. Mar 26, 2019 - 17:52 EDT
Investigating
We are investigating reports of slow performance with Uploads, Downloads and tagging documents in Logikcull.
Posted 7 months ago. Mar 26, 2019 - 16:19 EDT
This incident affected: Logikcull.com and Document Processing.