We are investigating an issue with front end availability of the application.
Incident Report for Logikcull
Resolved
Normal operations have resumed.
Posted over 2 years ago. Dec 30, 2016 - 12:33 EST
Investigating
The engineering team is investigating reports of inaccessibility to the application.
Posted over 2 years ago. Dec 30, 2016 - 11:55 EST