Login Issues
Incident Report for Logikcull
Resolved
Login is now operational with no errors reported for the last few hours. We will continue to closely monitor login activity.
Posted Apr 20, 2021 - 18:08 EDT
Update
The login system is currently operational, but still recovering. Users should be able to sign in, although intermittent issues are still possible. We will continue to provide updates.
Posted Apr 20, 2021 - 15:56 EDT
Investigating
Logikcull is currently experiencing an availability issue with application logins. Engineering teams are aware of the issue and researching options to recover access. We will update this page as soon as additional information is available.
Posted Apr 20, 2021 - 12:11 EDT
This incident affected: Logikcull.com, Document Processing, Application emails, AWS EC2, AWS S3, and DNS.