Issues with creating Downloads
Incident Report for Logikcull
Resolved
This incident has been resolved and all operations including download creation are back to normal.
Posted almost 2 years ago. Jun 13, 2017 - 20:32 EDT
Investigating
We are investigating reports regarding issues creating Downloads. We will update as soon as we have more information.
Posted almost 2 years ago. Jun 13, 2017 - 19:33 EDT