Reports of slow performance
Incident Report for Logikcull
Resolved
Full Logikcull performance has been restored.
Posted 6 months ago. Feb 16, 2019 - 16:21 EST
Investigating
We are investigating reports of slow performance with searching and tagging documents in Logikcull.
Posted 6 months ago. Feb 16, 2019 - 15:41 EST
This incident affected: Logikcull.com.